Results 1 to 6 of 6

Thread: vsutil.dll error

  1. #1
    kastle Guest

    Default vsutil.dll error

    On 7/31 I upgraded from ZA Internet Security to Extreme Security. Everything was working fine, but a few days later when shutting down Windows Update installed a patch. The patch install hung and I killed it after waiting 7 hrs. I logged in and eveything seemed ok, ZA was working fine. Upon shutdown, the patch installed and this time finished.

    Next time I logged in I got the error message: Validation failed for C:\Windows\system32\VSINIT.dll. You probably are missing a necessary root certificate.

    I uninstalled ZA Extreme Security based on recommendations and now when I try to reinstall I get the following error messages and the install fails: Installer failed to initialize. Please try to download and run the installer again. When I click OK on the error, I get the following error message: Could not load the DLL library
    C:\DOCUME~1\steve\LOCAL~1\Temp\081020222459\vsutil .dll
    (ls64bit).The specified procedure could not be found.

    Interestingly, MS Security Center says that Extreme Security reports that the Anti Virus and Firewall are working fine, but it is not installed.

    Any ideas how I can get the product installed again?

  2. #2
    kastle Guest

    Default Re: vsutil.dll error

    Forgot to add, I'm running Windows XP SP3.

  3. #3
    Join Date
    Oct 2005
    New York

    Default Re: vsutil.dll error

    Hi kastle:

    These instructions may be lengthy but they should provide you with successful results to get your ZA product successfully reinstalled.

    This applies to

    All ZoneAlarm products
    Windows 2000/XP


    I need to completely remove ZoneAlarm, or there are remnants of
    ZoneAlarm on my system


    If possible, first try to uninstall ZoneAlarm normally from your Start ->
    Programs -> ZoneAlarm menu. If this fails, or you want to ensure that all
    ZoneAlarm files were removed from the system properly, continue with the
    steps below.

    Please make sure that you have the latest version downloaded first:

    01.) Restart your computer
    02.) When you see the screen go black and it starts booting back up keep
    tapping the "F8" key (at the top of your keyboard)
    03.) This should bring up a menu. Choose Safe Mode off the menu by
    using the arrow keys on the keyboard to highlight Safe Mode and press
    04.) If you get a message asking to go to Safe Mode, choose Yes. If you
    get a help and support window, close this.
    05.) Once you are at the desktop, Click Start, My Computer
    06.) Click Tools, Folder Options, View Tab
    07.) Place a dot next to "Show Hidden Files and Folders"
    08.) Remove the check from "Hide Protected Operating System Files
    09.) Choose Yes to the warning
    10.) Click OK
    11.) Double click C:

    Note: In the future steps if you do not see any files or folders, please click
    the "Show Files" link to view them.

    12.) Double Click the Program Files Folder
    13.) Right Click the Zone Labs Folder (if present), click Delete, and choose

    NOTE: If you cannot delete the entire folder, please open the Zone Labs -
    > ZoneAlarm folder and delete out as many of the files listed here as

    14.) Close this window
    15.) Click Start, My Computer
    16.) Double Click the C:
    17.) Double Click the Windows Folder (It may also be WinNT)
    18.) Right Click the Internet Logs Folder, click Delete, and choose Yes
    19.) Double Click the System32 Folder
    20.) Right Click the Zone Labs Folder (if present), click Delete, and choose

    NOTE: If you cannot delete the entire folder, please open the Zone Labs
    folder and delete out as many of the files listed here as possible.

    21.) Locate and delete the following files in the System32 folder if they are

    - vsconfig.xml
    - vsxml.dll
    - vsregexp.dll
    - vsdata.dll
    - vsdata95.vxd
    - vsdatant.sys
    - vsmonapi.dll
    - vspubapi.dll
    - vsinit.dll
    - vsutil.dll
    - vswmi.dll
    - zlcommdb.dll
    - zlcomm.dll
    - zllictbl.dat
    - zpeng24.dll

    22.) Clear your Temp Directory per the instructions below.

    - Go to Start -> Run
    - Type %temp% and click OK
    - Select all of these files and delete them

    23.) Clear the Prefetch folder per the instructions below (Windows XP only).

    - Go to Start -> Run
    - Type Prefetch and click OK
    - Select all of these files and delete them

    24.) Remove the necessary registry entries:

    *Important Advisory: Deleting registry entries incorrectly may cause
    serious problems to your operating system, which may necessitate the
    need to reinstall it. Please make sure you are able to perform these
    deletions correctly before you decide to edit the entries. If you are not
    sure, you should seek help from someone who is familiar with editing the

    For information about how to edit the registry in Windows, from your
    desktop, click Start -> Run -> and type regedit. Click on Help -> Help
    Topics. Under the Contents tab, click Change Keys and Values (this may
    be found under the How to... section).

    Also, you should always make a backup of the registry before editing it.
    You can find this in the same section of the Help files.

    To remove the needed registry entries, go to Start -> Run and type in
    regedit. Choose OK, and use the folders on the left side of the Registry
    Editor window to navigate to the specified directories below. Note that you
    will remove the entire folder specified (eg, Zone Labs, vsmon, vsdatant):

    HKEY_LOCAL_MACHINE\Software\Zone Labs
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Servic es\vsmon
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Servic es\vsdatant

    25.) Close this window, then empty your recycle bin.
    26.) Restart the computer.
    27.) Try to install the latest version again

    NOTE - Links to sites other than are provided for the
    convenience of our users. ZoneAlarm does not provide, and is not
    responsible for, the content users may find on such sites.

  4. #4
    Join Date
    Jun 2004

    Default Re: vsutil.dll error

    Was the precise message by any chance the same as in

    If so read my suggestions there.

  5. #5
    kastle Guest

    Default Re: vsutil.dll error


    Thanks for the reply, these are the exact steps I followed when my ZA got messed up and that's how I got where I am. Cleanly removed ZA but still could not install.


    I just downloaded the Visual C++ 2008 SP1 Redistributable (x86) and it worked like a charm. Install worked fine. Which begs the question that if this is a required component, why does the installer program not warn you that it is not installed and provide a link to the Microsoft site to install it? Providing a cryptic error message and leaving users to troll the User Forum seems to be a bit random of an approach. Thanks for help.

  6. #6
    Join Date
    Oct 2005
    New York

    Default Re: vsutil.dll error

    Thank you kastle for posting back with your results. Glad everything worked out for you.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts