Results 1 to 7 of 7

Thread: Vista / ZoneAlarm 9 wireless issues with unidentified network

  1. #1
    cheresources Guest

    Thumbs up Vista / ZoneAlarm 9 wireless issues with unidentified network

    Like some others I've seen on the forums, I noticed that one of the laptops that we own wouldn't allow internet access after upgrading to ZA 9. The upgrade was done on two machines: a Dell (Vista 32 bit) and a HP Pavilion (Vista 64 bit). The upgrade on the Dell went just fine, all previous setting imported. The upgrade on the HP went fine too, but during the next boot up, Zone Alarm was denying access to the internet for our home wireless network (everything worked fine in ZA 8). I don't believe that this issue is exclusive to ZA as the upgrade worked on one of the laptops.

    In order to connect to the internet on the HP machine, we had to disconnect the wireless connection, shut down ZA, reconnect to the network, and restart ZA. Then, all was well. I spend the better part of a day trying to solve this problem, but finally settled for the following solution that I wanted to share with everyone.

    If the wireless internet connection is established BEFORE ZA starts, the connection will succeed. I've made a small script which will delay ZA's start up until the wireless connection is established (this assume that your computer connects to your wireless network automatically upon start up).

    Here's how you can institute this fix:

    1. In ZA, under "Overview" --> Preferences --> General, uncheck the box where is says to start ZA upon startup.

    2. Under the Windows start button, select Run and type "notepad.exe". Paste the following into this document:
    ===================================
    @echo off
    ping localhost -n 20 > nul
    start /b "" /d"C:\Program Files (x86)\Zone Labs\ZoneAlarm\" zlclient.exe
    ===================================
    Note: Alter the location of zlcient.exe accordingly if it differs on your computer.

    3. Save this file to:
    C:\Users\[UserName]\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup
    You can name the file anything you'd like (such as ZA_startup.bat), but be sure that the extension is *.bat (A windows batch file)

    4. The number "20" in the script above is the number of seconds that ZA will be delayed from starting up. 20 seconds works for me, but you can adjust it upward if your computer is a little slower to connect. If you make any changes, just save the file when you're done.

    5. Now, when you restart your computer, you'll see a small, black DOS-like window appear when your computer restarts. This window will appears for as long as the delay is set, then ZA will start and the window will disappear.

    I know this solution is perfect, but it got my wife's computer working again and she doesn't have to take any action...and that was my goal.

  2. #2
    bunnyfugger Guest

    Default Re: Vista / ZoneAlarm 9 wireless issues with unidentified network

    Quote Originally Posted by cheresources View Post
    Like some others I've seen on the forums, I noticed that one of the laptops that we own wouldn't allow internet access after upgrading to ZA 9. The upgrade was done on two machines: a Dell (Vista 32 bit) and a HP Pavilion (Vista 64 bit). The upgrade on the Dell went just fine, all previous setting imported. The upgrade on the HP went fine too, but during the next boot up, Zone Alarm was denying access to the internet for our home wireless network (everything worked fine in ZA 8). I don't believe that this issue is exclusive to ZA as the upgrade worked on one of the laptops.

    In order to connect to the internet on the HP machine, we had to disconnect the wireless connection, shut down ZA, reconnect to the network, and restart ZA. Then, all was well. I spend the better part of a day trying to solve this problem, but finally settled for the following solution that I wanted to share with everyone.

    If the wireless internet connection is established BEFORE ZA starts, the connection will succeed. I've made a small script which will delay ZA's start up until the wireless connection is established (this assume that your computer connects to your wireless network automatically upon start up).

    Here's how you can institute this fix:

    1. In ZA, under "Overview" --> Preferences --> General, uncheck the box where is says to start ZA upon startup.

    2. Under the Windows start button, select Run and type "notepad.exe". Paste the following into this document:
    ===================================
    @echo off
    ping localhost -n 20 > nul
    start /b "" /d"C:\Program Files (x86)\Zone Labs\ZoneAlarm\" zlclient.exe
    ===================================
    Note: Alter the location of zlcient.exe accordingly if it differs on your computer.

    3. Save this file to:
    C:\Users\[UserName]\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup
    You can name the file anything you'd like (such as ZA_startup.bat), but be sure that the extension is *.bat (A windows batch file)

    4. The number "20" in the script above is the number of seconds that ZA will be delayed from starting up. 20 seconds works for me, but you can adjust it upward if your computer is a little slower to connect. If you make any changes, just save the file when you're done.

    5. Now, when you restart your computer, you'll see a small, black DOS-like window appear when your computer restarts. This window will appears for as long as the delay is set, then ZA will start and the window will disappear.

    I know this solution is perfect, but it got my wife's computer working again and she doesn't have to take any action...and that was my goal.

    Hi cheresources,

    Thanks for your useful post.

    Regards...

    UPDATE:
    DISREGARD COMMENT ON USEFUL POST (the thanks remain) AND SEE GURUS POSTS! - THANKS GUYS
    Last edited by bunnyfugger; November 26th, 2009 at 01:49 AM. Reason: Post NOT useful!!

  3. #3
    Join Date
    Nov 2004
    Location
    localhost
    Posts
    17,285

    Default Re: Vista / ZoneAlarm 9 wireless issues with unidentified network

    Hi!
    1. is the a key weakness in the process. ZA will not load the antitampering processes (loaded even before log in) and will expose user to malware attacks.

    In other words, not a recommended action.

    Fax

    Click here for ZA Support
    Monday-Saturday 6am to 10pm Central time
    Closed Sundays and Holidays

  4. #4
    Join Date
    Jun 2006
    Location
    The 3rd Coast - South Central Texas
    Posts
    10,465

    Exclamation Re: Vista / ZoneAlarm 9 wireless issues with unidentified network

    I agree with Guru Fax;

    "Computers are expensive pieces of equipment. For the same reasons you lock your home and car (to keep others out), you need to have some type of Firewall & antivirus protection on your computer. There is an arms race out there between malware producers and antivirus software producers. And it escalates daily. Remaining unprotected even for the short period of time it takes to Boot up your computer and manually start ZoneAlarm is a sure-fire way to become collateral damage in this war. The cost to prevent and protect yourself is much lower than the cost of replacing your computer and restoring your identity."

    I strongly Advise to Keep "Start ZoneAlarm on Startup" checked, unless you are Uninstalling ZoneAlarm..
    GeorgeV
    ZoneAlarm® Extreme Security


    Click here for ZA Support
    Monday-Saturday__ 6am to 10pm Central time
    Closed Sundays and Holidays

  5. #5
    firedog Guest

    Default Re: Vista / ZoneAlarm 9 wireless issues with unidentified network

    Hi-

    Had the same problem, solved it by removing the wireless lan manager from my startup file.

    Windows wireless manager runs instead and everything works fine.

  6. #6
    cheresources Guest

    Default Re: Vista / ZoneAlarm 9 wireless issues with unidentified network

    I understand the security concerns and share them. I got the idea after watch the Dell computer reference in my original post boot up. The wireless connection was always established in the boot sequence prior to ZA firing.

    I'm open to alternative solutions which must be available because the problem wasn't present in version 8 of ZA. Has the change been identified?

  7. #7
    Join Date
    Nov 2004
    Location
    localhost
    Posts
    17,285

    Default Re: Vista / ZoneAlarm 9 wireless issues with unidentified network

    Quote Originally Posted by cheresources View Post
    I'm open to alternative solutions which must be available because the problem wasn't present in version 8 of ZA. Has the change been identified?
    Report the issue to ZA technical support so that it is properly troubleshooted or logged.

    Alternatively a new ZA beta is out, you can try it to see if the issue is resolved and feedback directly the developers. www.zonealarm.com/beta

    Cheers,
    Fax

    Click here for ZA Support
    Monday-Saturday 6am to 10pm Central time
    Closed Sundays and Holidays

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •