Hi everyone,
I've never really had trouble with Zone Alarm in the past but the past week or so has had me tearing my hair out.
I recently upgraded to the ZA:ES and, like most, about a week or two ago got the prompt to upgrade the software. It then asked for the restart and when it did, I couldn't access the internet. I found out that my network *and consequently my internet* drivers had been corrupted and removed. I thought that maybe ZA had picked up on a virus on my NW drivers and eliminated it for me but when I tried to re-install (From a clean uninstall) them (using the version from my manufacturer's website) my computer wasn't having any of it.
I then performed a system restore and they still weren't functioning. After many attempts at trying, by a sheer fluke it started working again * I think I had put it on hibernate*. But I needed to upgrade Zone Alarm still as a result of the restore. I did so. It restarted...and I lost my drivers again. Now, even thught I've tried all the tricks I was doing before, I can't get it to work. I don't want to have to stop using ZA as I think it's a good product, but I have no idea how to solve this. Any help or has anyone else had this problem?

PC: HP Pavilion Laptop tx 2000
OS: Windows Vista Home Premium
Network Driver: Broadcom 801.11 (wireless)

Merry Christmas everyone!

Metia

x

P.S. I have tried the work around mentioned here: http://forums.zonealarm.com/showthread.php?t=72454
But to no avail...