Results 1 to 5 of 5

Thread: Nothing happens: "Protection Is Up, UI is Initializing"

  1. #1
    goffyzig Guest

    Default Nothing happens: "Protection Is Up, UI is Initializing"

    This thread is being put up because someone from ZA has mistakenly closed a very important thread. I experienced this exact same problem trying to install a fresh copy of ZA on my laptop (Toshiba Satellite, Win Vista 32bit, SP1

  2. #2
    goffyzig Guest

    Default Re: Nothing happens: "Protection Is Up, UI is Initializing"

    May 19th, 2009, 05:07 PM
    drobison http://forums.zonealarm.com/images/s...er_offline.gif
    Junior Member
    Join Date: May 2007
    Posts: 4


    http://forums.zonealarm.com/images/icons/icon1.gif Re: "Protection Is Up, UI is Initializing"
    I have a Toshiba Satellite laptop (Vista Home Premium SP1 32-bit, AMD Turion 64-bit 2GHZ, 2GB RAM) and have been unable to successfully install ZoneAlarm ISS 8.0.298.035. The problem was that the tray icon would display "Protecion is up, UI is initializing" when hovered, and the UI could not be opened. I spent many hours over many days reading forumns, installing ZA, deinstalling, cleaning up after deinstall, disabling other software, changing settings, reinstalling, etc. All without much luck until today. I hope this helps some other poor soul out there.

    All I did was copy the file vsdatant.sys from c:\windows\system32\zonelabs\ to c:\windows\system32\drivers\, and restarted Windows. ZA then started normally and I was able to open the UI, download updates and run scans. Note that this fix is for Vista since my XP Pro system expects vsdatant.sys in C:\windows\system32\

    Following are some details about how I found the solution -- they have been shortened to focus on the most valuable clues and information. Maybe there will be enough here for ZoneLabs or the smart people who read these forums to figure out what really went wrong.

    I started like most others by deinstalling and reinstalling. When that didn't work, I tried deinstalling and purging the various bit of leftover data before reinstalling. Then I started shutting off other software and services using MSCONFIG. None of that helped. I found a forum entry that suggested removing some Atheros software that comes on Toshiba laptops but didn't do so for fear of making matters worse. At this point all I knew was that ZA's installation seemed to be very touchy, Toshiba laptops seemed to be particularly prone to having the problem, and that no one really had a solid explanation or fix.

    My first big break came when I saw an error message in one of the Windows event logs that said the vsdatant service couldn't start because a file wasn't found. I searched my hard drive and found a copy in C:\windows\system32\zonelabs. I copied it to C:\windows\system32\ based on another forum entry but that didn't help. By looking at the TrueVector service, I could see that it had a dependency on the vsdatant service, but vsdatant didn't show up in the list of services.

    Break #2 came when I found vsdatant in Device Manager (after making hidden devices visible) and could see vsdatant wasn't working. The message was: "This device is not present, is not working properly, or does not have all its drivers installed. (Code 24)". I'd get a message saying the file couldn't be found when I tried to start it (on the Drivers tab in the properties dialog). Unfortunately, the message didn't say exactly which file or where it should be located. There was also a possibility that something vsdatant needed (such as another DLL) was missing.

    Break #3 came when I searched the registry and found a possible location for vsdatant.sys. The path for the "ImagePath" key was: HKEY_LOCAL_MACHINE\system\ControlSet001\Services\v sdatant, and it pointed to C:\windows\system32\drivers.

    Before trying the fix, I speculated that somehow the ZA installer aborted and just didn't do the copy. I was now concerned that there were other things (such as making registry entries) that didn't get done. My fears are diminishing as ZA continues to operate normally. I have an AV scan running now, and then I'll start enabling all the things I disabled and see if ZA still runs.

    My advice to others with the "UI is Initializing" problem is to:
    a. Use Device Manager, make hidden devices visible, look for vsdatant under "Non-Plug and Play Drivers" and see if it is working.
    b. If not, look for vsdatant.sys in either C:\windows\system32, or c:\windows\system32\drivers. If you don't find it, my fix may work for you.
    c. Use the registry editor (RGEDIT) to find the key I mentioned above, and note the path.
    d. Look for vsdatant.sys in C:\windows\system32\zonelabs. Hover over the name to make sure it's the right version. Copy it to where Windows expects to find it.
    e. Restart Windows

    Thanks to all those who posted information about the problem that gave me the breaks I needed. Hopefully this is a little payback.

    Good luck!

  3. #3
    goffyzig Guest

    Default Re: Nothing happens: "Protection Is Up, UI is Initializing"

    You can refer to the whole original thread here. This problem has been ongoing for months and ZA developers have not fixed it. They also closed the thread as if the problem is resolved on the ZA software. IT IS NOT.

    Original Thread: http://forums.zonealarm.com/showthread.php?t=63698

    Hope this helps others.

  4. #4
    Join Date
    Nov 2004
    Location
    localhost
    Posts
    17,287

    Default Re: Nothing happens: "Protection Is Up, UI is Initializing"

    Hi!
    ZA developers or ZA staff do not read or monitor this board. You should report to them directly either with the beta feedback form (if you are using a ZA beta) or via the official ZA technical support. Link to ZA technical support in my signature.

    Support is free of charge if you have a valid license

    Cheers,
    Fax

    Click here for ZA Support
    Monday-Saturday 6am to 10pm Central time
    Closed Sundays and Holidays

  5. #5
    iusoccer Guest

    Default Re: Nothing happens: "Protection Is Up, UI is Initializing"

    I am running Windows XP (SP3), Dell Desktop, Pentium 4 2.6GHz, 2 GB Ram

    I experienced the same problem and this thread helped point me in the right direction. The original fix was for Vista and would not work for XP. What I discovered was that vsdatant.sys was not where it was supposed to be. I searched for the file and found it. I copied it in to C:\Windows\system32\drivers along with vsdata.dll

    This is not enough to fix your problem. You have to go into your registry and manual adjust where it is going to look for this driver. Look in HKEY_LOCAL_MACHINE\system\ControlSet001\services\v sdatant

    When you are in this registry you are going to have to edit where it looks for this driver. On the right hand side of the screen right-click on ImagePath and select Modify. Once you are in the box that pops up edit the Value data to be System32\drivers\vsdatant.sys

    Restart your computer and the problem should be solved. If not good luck hunting for the solution. I had talked to a ZA representative and done all the uninstalling, reinstalling, uninstalling, cleaning, editing my registry, and all that junk did not fix the problem. What I just told you about above fixed it and it updated right away and scanned no problem.

    If you are having problems with an error message that says something about vsdatant and it pops up every 2 minutes you need to locate vsdatant and delete it (which you will have to do in Safe Mode). I found mine C:\Windows\system32 - MAKE SURE you have copied it to the correct place before you delete it from where it is not supposed to be.

    Aim small, miss small
    iusoccer

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •