I'm having a big problem with Zonealarm Extreme Security in which after a few hours I lose my connection to my home network. When it happens, I am unable to connect to anything on the network, including the router, my other computers on the network, or anything on the internet. My newsgroup reader provides the only clue as to what is happening as it tells me "there is not enough memory to initialize the winsock driver", other than this message I get no errors in the event log.

The affected computer has a wired connection to the router, one of the XP computers has a wired connection and the other has a wireless connection. My other computers are both using windows xp pro x86 and also have zonealarm but this problem never happens on them. I had the same problem with zonealarm in vista home premium x86 on this machine, but I removed vista and put xp on here and the problem didn't happen. This happens on a clean install of Win7x64 with only zonealarm installed too.

Affected versions of zonealarm...
Extreme Security 9.0.114.000
Extreme Security 9.1.061.000 beta
Security Suite (free trial, current version)

System Specs
System Manufacturer/Model Number: Dell XPS 720
OS: Windows 7 professional x64
CPU: QuadCore Intel Core 2 Quad Q6600, 2400 MHz
Motherboard: Dell XPS 720 - nVIDIA nForce 680i SLI
Ethernet Card: integrated Broadcom NetXtreme 5754
Router: DLink DIR-655
Graphics Card: NVIDIA GeForce 8800 GT (512 MB) SLi
Sound Card: Creative X-Fi XtremeGamer Fatal1ty Pro

All of my hardware drivers are up to date.

The only way for me to restore my connection is to reboot the computer. I have tried repairing winsock and LSP but the problem returns everytime. I have also tried disabling ipv6. Using the repair and diagnostics of the nic card and connection does not work, it only reports that there is a problem causing the test to fail when trying to connect to the microsoft test address. I have also tried disabling and reenabling the nic card. I have also run deep virus, rootkit, and malware scans, and have run memtest86+ for 17 passes (around 34 hours worth of testing).

No matter what I do though, I still get the same "not enough memory to initialize winsock" problem.