Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: zlclient.exe using 29% cpu

  1. #1
    david21 Guest

    Default zlclient.exe using 29% cpu

    Just updated my laptop (which hadn't been used for months) with ZA Pro 9.1.008.000. Machine seemed very slow, so checked Windows Task Manager and the process zlclient.exe was using 29% cpu. Left it running for an hour and still the same. Close ZA and cpu use drops to virtually zero.

    So did a full uninstall (untick load at startup, safe mode, uninstall, ran cpes_clean.exe, checked that folders, logs etc had gone) then downloaded the new version again from ZA website (via Firefox) and reinstalled (selecting standard installation). Did notice that my reg code was still there, so must have been something left from old installation.

    Problem still the same. Stopped AV program (Avast), no difference, nothing else running. Event log shows nothing suspicious.

    My desktop PC works fine, most of the time zlclient.exe is showing 0% cpu usage.

    Any idea what the problem is? Any other diagnostics to try?

    (XP sp3, 2.4G P4 cpu, 1Gb memory, XP fully up to date)

  2. #2
    garywa Guest

    Default Re: zlclient.exe using 29% cpu

    Been posted several times. Try starting here: http://forums.zonealarm.com/showthread.php?t=73184

  3. #3
    david21 Guest

    Default Re: zlclient.exe using 29% cpu (SOLVED BUT...)

    Thanks garywa.

    Turning off the debug logging (as per the linked post above) has stopped zaclient.exe using the cpu to excess.

    However, is there still an underlying problem that's causing all this logging? I'd be happier if I knew what it was and does it need fixing.

  4. #4
    garywa Guest

    Default Re: zlclient.exe using 29% cpu

    Most likely, yes. Something is causing the logging. But, there have been other topics here discussing the logging level upon install of ZA being set to High. I'm not sure if this was ever confirmed by ZA tech support, but I think so. There are 2 debug levels that can be set - Default and High. There was discussion here that the debug level may have been set to High rather than Default.

    I have turned Off debug on both my PCs to save CPU cycles. I haven't bothered trying to figure out why my PCs had the activity. I don't worry about it.

    ZA tech support is the only one who can read and interpret the tvDebug.log file and the only time you would need to get involved with that file is if you were working with ZA tech support troubleshooting a specific problem and then they would provide you with detailed instructions on setting and submitting the log file.

  5. #5
    garywa Guest

    Default Re: zlclient.exe using 29% cpu

    As I stated in the post above, only ZA tech support knows how to read that log file.

    If you want, you could always contact tech support, explain the scenario and see what they say. If you do contact them and learn anything interesting, please post back for the rest of us.

  6. #6
    DJ Tenagra Guest

    Default Re: zlclient.exe using 29% cpu

    I'm having the same problem. I chased down all the post links referenced below, but none of them helped. I'm using ZA free. One of the posters said they were using ZA free too, but I could not find the options they referenced. I would love to find out if it's zlclient debug log activity using up a large amount of my CPU time, but where can I find that option to turn it off in the free version?

  7. #7
    garywa Guest

    Default Re: zlclient.exe using 29% cpu

    Quote Originally Posted by DJ Tenagra View Post
    I'm having the same problem. I chased down all the post links referenced below, but none of them helped. I'm using ZA free. One of the posters said they were using ZA free too, but I could not find the options they referenced. I would love to find out if it's zlclient debug log activity using up a large amount of my CPU time, but where can I find that option to turn it off in the free version?
    Can you tell us which specific topic and option you are referencing above? Even though I don't use the free firewall, it might help one of us to be able to steer you in the right direction.

    Also, what version number of ZA Free do you have installed?

  8. #8
    DJ Tenagra Guest

    Default Re: zlclient.exe using 29% cpu

    Yes, for instance, in the second entry I see, that starts "Been posted several times." I believe that is one example, if you chase down you will find references to someone going to the Alerts and Logs page in ZA, and checking options such as Debug logging being set from High, down to completely Off. I can find no such options. On one of the links I chased down I found someone talking like they had ZA free and had those interface options, but I couldn't find those options anywhere in my installation. I've uninstalled and reinstalled twice now. I'm starting to guess that the free version just has debug logging set on, with no user interface to change it, because I'm seeing all the other described symptoms, like the high CPU usage and the tvDebug.log growing to gigabytes in size. All of this became painfully noticeable just a few weeks ago. Perhaps after some version update?

    I currently have this on two machines, one faster, one slower. The faster machine shows zlClient taking about 20% CPU constantly. The slower machine has it taking about 45% CPU constantly, which makes that machine almost unusable.

    The ZA free version I have installed reports:
    ZoneAlarm version:9.1.007.002
    TrueVector version:9.1.007.002
    Driver version:9.1.007.002

    Both machines are running XP Pro SP3.
    Last edited by DJ Tenagra; March 29th, 2010 at 10:20 PM. Reason: Got a quote from another post wrong

  9. #9
    naivemelody Guest

    Default Re: zlclient.exe using 29% cpu

    See ZA tray icon bottom right. Hold down keys 'Shift' and 'Ctrl' together and then right click on ZA tray icon > see "Set debug level" now you can set 'Debug categories' > to "Off" > OK > to restart.
    ________________________________________
    Other possiblities: check your 'task manager' to see for only one "zlclient.exe" - it is possible to have two when in a corrupted mode.

    Other possible- is software conflict. List any other Security Programs installed. Anti-virus, other anti-spyware, monitors, back-ups, etc.

    __________________________________________
    NaiveMelody NYC -3-29-10 - Clocks - Coldplay

  10. #10
    findley Guest

    Default Re: zlclient.exe using 29% cpu

    Also, make sure you are not running two firewalls and that the Windows firewall is turned off.

    Findley

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. vsmon.exe+zlclient.exe = 100% CPU Usage :(
    By unipatatas in forum General - Questions that don't fit any other category
    Replies: 3
    Last Post: May 29th, 2008, 01:31 PM
  2. CPU stuck on %100! vsmon.exe VS zlclient.exe
    By jamminjammin in forum Windows and ZoneAlarm Messages and Alerts
    Replies: 3
    Last Post: May 22nd, 2008, 08:08 AM
  3. Replies: 39
    Last Post: December 12th, 2007, 09:55 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •