Results 1 to 7 of 7

Thread: Remember this setting

  1. #1
    pkquat Guest

    Default Remember this setting

    Please make a option so one can make the "Remember this setting" check box UNCHECKED by DEFAULT.

    I have been using ZA since version 1. Somewhere around version 5 or 6 the "Remember this setting" check box and the Smart Defense Adviser behavior became virtually random. Some times the box is checked sometimes not, for the SAME programs. It changed behavior in almost every main and sub version updates. There has not been any consistency.

    I recently updated from version 9.0 to 9.1 and the "Remember this setting" check box is now ALWAYS checked. It was much better in version 9.0. The only reason I updated was because version 9.0 did not stop some of the re-direct malware/virus' going around. One of which I got.

    I have not gotten infected in 6+ years. Some of this is due to the fact that I set most programs to ask permission to act as server, and especially access the internet. I like to control when a program can access what so I know what is going on. The Smart Defense Adviser pop up has stopped a few attempts when a file, link, or website has tried to trigger a program to run unexpectedly.

  2. #2
    Join Date
    Nov 2004
    Location
    localhost
    Posts
    17,291

    Default Re: Remember this setting

    You have to set SmartDefence Advisor to OFF to get the box UNchecked.
    It has always been like this. If not your ZA settings were actually broken.

    Cheers,
    Fax

    Click here for ZA Support
    Monday-Saturday 6am to 10pm Central time
    Closed Sundays and Holidays

  3. #3
    pkquat Guest

    Default Re: Remember this setting

    I will concede that for version 9.0 I may have turned Smart Defense Advisor Off, because that vaguely rings a bell now as the solution.

    However, I know for a fact that it did not always operate this way. In the earliest versions Smart Defense Advisor would advise without checking the box by default. It may show a green light, provide information and recommend the "Remember this setting" box be checked, but would NOT check it by default. It would always offer advise to situations and any traffic etc. I am pretty sure this was the case as well for some of the later versions with Smart. I recall some versions being mixed, or possibly learning responses regarding the check box. I remember this because I never checked "Remember this setting" for Internet Explorer, but on the rare occasions I did use it, it was never checked by default, yet I still got advise and other rarely used programs or first installs sometimes had the "Remember this setting" box checked by default.

    Regardless, I would like to get Smart Defense Advisors advise, capabilites, and "suggestions" on how to proceed, but allow the user to choose whether I want to see the pop up box each time. If I don't want to I will check the box. (PS this is how Windows and many other programs operate. Very rarely is the "Don't show me this message again" box checked on default.) Unchecking the box each time is a very big added hassle instead of just a single key stroke or single click on a large button. Having it checked by default means it is also prone to accidentally accepting a suggested setting and not knowing what just got set.

    Having the box the box checked by default for for Smart Defense Advisor to work seems very illogical. Maybe there should be 4 settings for it, or a setting check box next to Manual to "Accept Smart Defense Advisors recommendations by Default."

  4. #4
    Join Date
    Nov 2004
    Location
    localhost
    Posts
    17,291

    Default Re: Remember this setting

    I have the impression you make the issue more complex then it actually is...
    Personally I prefer the box checked since I don't want to be bored everytime if I forget to check it!

    As the latins were saying "De gustibus non est disputandum!"

    Cheers,
    Fax

    Click here for ZA Support
    Monday-Saturday 6am to 10pm Central time
    Closed Sundays and Holidays

  5. #5
    pkquat Guest

    Default Re: Remember this setting

    It's actually quite simple and logical. I would like to just receive the advise from the Advisor without making decisions for me. And Users who don't want ZA to remember the setting have to uncheck it EVERY time the application is used vs. those who forget to check the box. Add to that the variety of boxes that are unchecked by default because ZA is not sure about the program.

    As for tastes, I have found the majority of programs, including initial versions of ZA, default to having things like this unchecked to avoid people accidentally accepting something they didn't mean to.
    Last edited by pkquat; March 25th, 2010 at 09:08 AM.

  6. #6
    Join Date
    Nov 2004
    Location
    localhost
    Posts
    17,291

    Default Re: Remember this setting

    Yes, simply UNtick the box. The design is novice friendly. It would be counter productive, many that are forgetting to check the box will be bored by the warning and will think its a ZA problem. Most common action for a normal user is to 'remember' and not the reverse.... are you following the logic? Settings follow the logic of the most and not of the few....

    But... indeed "De gustibus non est disputandum!"

    Fax

    Click here for ZA Support
    Monday-Saturday 6am to 10pm Central time
    Closed Sundays and Holidays

  7. #7
    Join Date
    Aug 2009
    Location
    Texas Gulf Coast
    Posts
    1,648

    Default Re: Remember this setting

    Quote Originally Posted by pkquat View Post
    It's actually quite simple and logical. I would like to just receive the advise from the Advisor without making decisions for me. And Users who don't want ZA to remember the setting have to uncheck it EVERY time the application is used vs. those who forget to check the box. Add to that the variety of boxes that are unchecked by default because ZA is not sure about the program.

    As for tastes, I have found the majority of programs, including initial versions of ZA, default to having things like this unchecked to avoid people accidentally accepting something they didn't mean to.

    In Manual mode, you will receive Program alerts when programs request access and can set the permission on your own.

    You could try the following :

    In ZASS I have Program Control set to Maximum and SmartDefense Advisor set to Manual.If you want a program to ask to Allow or Deny with Apply this setting untick do the following.

    In Program Control / Programs right click and select Remove the program that you want to ask Allow or Deny and with Apply this setting untick.

    Launch the program again.When Alert pops up.It should now be untick an asking to Allow or Deny.

    Footnote : Microsoft Catalog Utilization is disable.

    This works for me.

    Have a nice Day
    Last edited by Sky Soldiers; March 25th, 2010 at 03:51 PM. Reason: rephrase & Footnote

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Remember programme setting
    By timtpd in forum ZoneAlarm Configuration
    Replies: 1
    Last Post: May 24th, 2008, 02:43 PM
  2. Replies: 1
    Last Post: December 18th, 2007, 07:21 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •