I have been trying to update to the latest version of zone alarm but I keep getting a message that I need to update windows. When I try to update windows it says the update I am trying to install is older then the one currently on my system any ideas?