Results 1 to 6 of 6

Thread: [SOLVED] XP SP2, ZA 9.2.057.000 update: vswmi.dll issues and installation error

  1. #1
    sharonb Guest

    Default [SOLVED] XP SP2, ZA 9.2.057.000 update: vswmi.dll issues and installation error

    I tried to update automatically and an error came up while "copying ...system32/vswmi.dll" which interrupted the installation and caused me to be stuck after the last version was uninstalled (probably not completely) and before the new version was installed.

    I tried to download the setup file again, this time from the website - zaSetup_92_057_000_en.exe. I ran the setup as "quick installation" only to have the installation process abort at the same point ("vswmi.dll")

    So I looked around in the forums and saw that I need to clean the older version of ZA using the cleanup utility, so I downloaded it, saved it on the desktop, tried to run it and got the following error:

    TrueVector Service has encountered a problem and needs to close. We are sorry for the inconvenience...

    followed by:

    Cleanup Error: You are not authorized to remove the client from this machine. Reason: This installation does not have a password set. A password is necessary to authorize the cleanup.

    I have only one user on my computer, with no password, so I have no idea what password to put in order to run it on "Administrator" and it does not accept the password line being left blank.

    So I downloaded CC Cleaner as advised somewhere in the forum, ran it, deleted all of the setup files, and emptied the bin, restarted the computer, tried everything from the begining, only to have the exact same thing happen again.


    I really don't know what to try next, so hopefully someone will have an idea of how to solve this mess...


    Thanks,

    Sharon

    (by the way i'm running on XP Professional SP2, and at the moment have the windows firewall running, and AVG antivirus, and all the downloads were from iexplorer 8 with no download manager or speedup)

  2. #2
    Join Date
    Nov 2004
    Location
    localhost
    Posts
    17,291

    Default Re: Lots of Problems with Updating ZA free

    Hi!

    first of all SP2 may be the cause of the problem. ZA works best on fully patched system. Yours is pretty outdated. There are literary hudreds of bugs and security vulnerabilities so far fixed in SP3 and follow up patches.

    Aside this consideration try to manually clean your system of all ZA left overs (including vswmi.dll). You will need to do it by booting in SAFE MODE. Don't proceed further if you are not able to remove them fully. See here:

    I cannot find or run the ZoneAlarm uninstall program (XP/2000)

    Remember to shutdown any tool running before installing (e.g. AVG).

    Click here for ZA Support
    Monday-Saturday 6am to 10pm Central time
    Closed Sundays and Holidays

  3. #3
    Join Date
    Dec 2002
    Location
    San Carlos, California
    Posts
    1,636

    Default Re: XP SP2, ZA 9.2.057.000 update: vswmi.dll issues and installation error

    I agree with Fax.

    Install SP3 and then install all other patches and fixes from MS.

    Sounds like something is missing from your OS and thus cant install ZA correctly.


    Forum Moderator
    Click here for ZA Support
    Monday-Saturday__ 6am to 10pm Central time
    Closed Sundays and Holidays

  4. #4
    sharonb Guest

    Default Re: XP SP2, ZA 9.2.057.000 update: vswmi.dll issues and installation error

    Thanks, I'll try that and let you know how it goes...

    Sharon

  5. #5
    sharonb Guest

    Default Re: XP SP2, ZA 9.2.057.000 update: vswmi.dll issues and installation error

    I updated to SP3 mode and tried again, but it didn't work, so I removed the files in safe mode and it worked. I guess the combination of the two did it..

    Thanks,

    Sharon

  6. #6
    Join Date
    Nov 2004
    Location
    localhost
    Posts
    17,291

    Default Re: XP SP2, ZA 9.2.057.000 update: vswmi.dll issues and installation error

    Great! I am closing this thread since the issue is resolved.

    Please do not hesitate to PM me if you need to re-open it or just post a new message for any other ZA related issue.

    Cheers,
    Fax

    Click here for ZA Support
    Monday-Saturday 6am to 10pm Central time
    Closed Sundays and Holidays

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [SOLVED - ZA SERVER ISSUES] Persistent AV update download error
    By ananda in forum ZoneAlarm Anti-virus & Anti-spyware
    Replies: 8
    Last Post: September 21st, 2009, 11:36 AM
  2. Replies: 1
    Last Post: April 7th, 2008, 05:57 AM
  3. ZA 7.0.462.000 Upgrade/Startup Issues on Win XP Home SP2
    By tedallen in forum ZoneAlarm Installation
    Replies: 8
    Last Post: January 18th, 2008, 11:58 PM
  4. Replies: 0
    Last Post: July 22nd, 2006, 02:53 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •