I have been having problems with my new desktop computer since May 2010. I would get the BSOD caused by with an error 7F. Finally fixed it by doing the following:-

"Click Start, and then click Control Panel.[*]Under Network and Internet, click View network status and tasks.[*]Click Change adapter settings.[*]Right-click Local Area Connection, and then click Properties.[*]In the This connection uses the following items list, double-click Internet Protocol Version 4 (TCP/IPv4), click Advanced, and then click the WINS tab.[*]Click Disable NetBIOS over TCP/IP, and then click OK three times"

I was getting a BSOD on a regular basis (every hour or so) and originally did not stop it untill I completey uninstalled Zonealarm.

I have Windows 7 64 bit, Zonealarm Extreme 9.3.014.000