Results 1 to 5 of 5

Thread: [SOLVED] ZA does not block Firefox and Chrome when it should

  1. #1
    simmorg Guest

    Default [SOLVED] ZA does not block Firefox and Chrome when it should

    Hello all,

    I seem to have the opposite problem to many people in that Zone Alarm does not block internet access when it's supposed to. In fact I'm now using Firefox even though the program has been set to block in Zone Alarm. I've been using Zone Alarm (version 9.2.057) and I'm sure it did work for a while. It does block Internet Explorer if I set it to do that but not Firefox or Google Chrome. I only noticed there was a problem because a new program that I knew would want internet access gained it without me being asked by ZA. Since I first installed ZA I've never messed around with the settings so I guess most of them are on the default settings.

    I'd appreciate any help that people could provide. I've had a search around the forum and I haven't seen any one else with the same problem but apologies if I've missed a thread on this.

    By the way if this is relevant I'm using Windows 7.

    Thanks.

  2. #2
    xmxm Guest

    Default Re: ZA does not block Firefox and Chrome when it should

    I have experience with similar behavior, the ZAFree refused to block some of my programs (Firefox included):

    http://forums.zonealarm.com/showthread.php?t=74343

    I think there was either a problem in ZAFree (maybe something connected to the ZAFree internal predefined list of the known apps and their settings) or there was a conflict between ZAFree and other security app (in my case MS Forefront antivirus).

  3. #3
    Join Date
    Nov 2004
    Location
    localhost
    Posts
    17,288

    Default Re: ZA does not block Firefox and Chrome when it should

    Quote Originally Posted by simmorg View Post
    In fact I'm now using Firefox even though the program has been set to block in Zone Alarm. I've been using Zone Alarm (version 9.2.057) and I'm sure it did work for a while.
    If it worked before then you may have problems with the ZA settings that got corrupted. Also ensure you don't have any security tool acting as proxy intercepting/diverting the internet calls to check for malicous code before ZA get them (e.g. Avast, NOD and potentially all security software that filters web calls).

    To reset the ZA settings, do the following:

    1.) Hold down the Ctrl and Shift keys together
    2.) Right click on the ZA icon near your clock
    3.) Choose 'Reset' from the box that comes up
    4.) Choose Yes on the Reset Settings dialog box
    5.) When prompted, choose OK to restart your system
    6.) Follow the on screen configuration prompts after reboot

    Then before running firefox or chrome, go to ZA program control and turn OFF Smartdefense (to avoid autorules been created by ZA for known safe applications).

    Now it should ask for permission for firerfox as soon as it tries to access the net (test it with your antivirus solution turned off, to exclude issues of proxy filtering).

    Cheers,
    Fax
    P.S. Also note that MS applications are whitelisted. You need to turn UNcheck "Enable Microsoft Catalogue Utilization" to operate fully in manual mode.
    Last edited by fax; September 9th, 2010 at 01:31 AM.

    Click here for ZA Support
    Monday-Saturday 6am to 10pm Central time
    Closed Sundays and Holidays

  4. #4
    simmorg Guest

    Default Re: ZA does not block Firefox and Chrome when it should

    Quote Originally Posted by fax View Post
    If it worked before then you may have problems with the ZA settings that got corrupted. Also ensure you don't have any security tool acting as proxy intercepting/diverting the internet calls to check for malicous code before ZA get them (e.g. Avast, NOD and potentially all security software that filters web calls).

    To reset the ZA settings, do the following:

    1.) Hold down the Ctrl and Shift keys together
    2.) Right click on the ZA icon near your clock
    3.) Choose 'Reset' from the box that comes up
    4.) Choose Yes on the Reset Settings dialog box
    5.) When prompted, choose OK to restart your system
    6.) Follow the on screen configuration prompts after reboot

    Then before running firefox or chrome, go to ZA program control and turn OFF Smartdefense (to avoid autorules been created by ZA for known safe applications).

    Now it should ask for permission for firerfox as soon as it tries to access the net (test it with your antivirus solution turned off, to exclude issues of proxy filtering).

    Cheers,
    Fax
    P.S. Also note that MS applications are whitelisted. You need to turn UNcheck "Enable Microsoft Catalogue Utilization" to operate fully in manual mode.
    Thanks very much, this worked great.

    I couldn't find the option concerning Microsoft but there was one called "Allow certified Microsoft programs to run automatically" which was unchecked. I guess this was why Internet Explorer didn't work if I blocked it (maybe?).

    Anyway after resetting ZA and turning off Smartdefense ZA worked properly.

    Thanks again.

  5. #5
    Join Date
    Nov 2004
    Location
    localhost
    Posts
    17,288

    Default Re: ZA does not block Firefox and Chrome when it should

    You're welcome!
    Glad to hear the issue is resolved and thank you very much for taking the time to report back.

    I am closing this thread since the problem have been addressed. Do not hesitate to PM if you need to re-open it.

    Cheers,
    Fax

    Click here for ZA Support
    Monday-Saturday 6am to 10pm Central time
    Closed Sundays and Holidays

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 4
    Last Post: July 1st, 2010, 05:36 AM
  2. [SOLVED] Browser Security "OFF" -> uncheck "Block Reported Web Forgeries" in Firefox
    By fxp in forum Windows and ZoneAlarm Messages and Alerts
    Replies: 2
    Last Post: April 18th, 2010, 08:05 AM
  3. firefox and chrome..am I still protected?
    By voodooevil in forum Off-Topic
    Replies: 3
    Last Post: January 24th, 2010, 01:32 PM
  4. Firefox 3.5.3 and Google Chrome Sudden Failures
    By grahamblanca in forum ZoneAlarm Configuration
    Replies: 1
    Last Post: September 16th, 2009, 11:37 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •