ok, I had a program come up that wanted access to the internet that I did not reconize,
when I clicked on the Zone Alarm "More Info", it starts Firefox up instead of my Internet Explorer.
Firefox is NOT my default browser and I went in to program defaults and made sure it wasnt.

I do not want Zone Alarm using Firefox when I need online help!

I have been using Zone Alarm free firewall on and off for years and I have never had this problem before.
I just got a new laptop and installed ZoneAlarm Free Firewall on it, I did not install the toolbar or any of the other ****, just the firewall.

Any help is greatly appreciated.
I just need to know where to go in the Zone Alarm settings to to open with the REAL default browser, not what it thinks the default browser should be.