I have a LAN of several computers, but only mine runs ZoneAlarm Pro
(version:9.3.014.000
TrueVector version:9.3.014.000
Driver version:9.1.522.000)

My computer and my Server are both running Windows 7 Ultimate. I have a homegroup set-up, and various shared folders.

If I run a program that resides on my Server (to install something for example), by accessing it via <\\Server\folder> 9/10 my computer just hangs in limbo, with the "working" mouse icon and does not let me open Task Manager or anything, but it is not a freeze-up.

I have to press the RESET button to get everything back to normal.

I have tried running programs without ZA running, and I NEVER get this problem, anyone know what is happening?

ZA has a Trusted zone set-up for my LAN.

Regards: Demon

System Info
=========

Operating System
MS Windows 7 Ultimate 64-bit
CPU
Intel Core 2 Quad Q9450 @ 2.66GHz @ 3.60GHz
Yorkfield 45nm Technology
RAM
8.0GB Dual-Channel DDR2 @ 539MHz (5-5-5-15)
Motherboard
EVGA 132-CK-NF78 (Socket 775)
Graphics
G2420HDBL @ 1920x1080
512MB GeForce 8800 GTS 512 (EVGA)
Hard Drives
488GB Western Digital WDC WD50 00AAVS-00ZTB SCSI Disk Device (Unknown)
Optical Drives
HP DVD Writer 640b ATA Device
Audio
Creative Audigy Audio Processor (WDM)