I recently updated my ZoneAlarm extreme security, Forcefield was working fine with Firefox 3.6.13 before this, but after updating when trying to open Firefox I got the notorious "Error: Platform version '1.9.2.8' is not compatible with minVersion >= 1.9.2.13 maxVersion