Okay, I installed Firefox 3.6 which is the currently approved version; not easy to find since Firefox hides it on their site because they want everyone on the newest version.
But anyway, still having this Error mssg when I try to start Firefox:
XUL Runner
Error: Platform version 1.9.2.15 is not compatible with...

But if I turn forcefield off, then I can start Firefox. Also, with Firefox off, if I click on the Forcefield icon and drag to anything other than "about" then I get that same error mssg above. So this is clearly a Forcefield problem. What should I do about it?

Thanking you well in advance for your help,
Michael