I just tried to install Firefox 6.0.2. When ZA 10.2 ISS is active and I attempt to open Firefox, I get the error: "Error: Platform Version 6.0.2 is not compatible with mini version >=6.0, max version <=6.0". (Got the same error with v. 6.0.1). Firefox will open if Zonealarm is deactivated.

Is there a fix or workaround? I've looked in my program control settings, and Firefox and Firefox Helper all are checked.

Thanks in advance.