Considering you have reverted back to previous version I will close this thread since the issues does not apply anymore.

Please note that security tools are you first line of defense and running old security tools is like running no tools.

If you keep having problem with the new release its best you start looking for an alternative solution but up-to-date. This is always better than running an old and potentially vulnerable firewall.

Thanks,
Fax