I'm getting a ZoneAlarm Service Agent popup saying:

YOU ARE NOT PROTECTED: You are using an old version of ZoneAlarm Free Firewall that is no longer supported. Update your software to get protection from new threats. Click OK to download your FREE UPDATE now.

with options for updating now, or remind me later.

Is this a legitimate ZoneAlarm pop-up or is it a sign of virus/spyware infection? Anybody ever seen this before?