A Kaspersky driver in the Windows/System32 folder on my Windows XP SP3 system (klif.sys vs. 8.4.076) dates from 10/12/09 or even earlier. (I won't go into why I'm running version 9.x of ZoneAlarm Extreme Security, as that's covered in another thread.) What I want to know is whether this version of klif.sys is actually "current" in ZAES 9.3 (which dates from July 26, 2010 and later) or in 10.x, or whether I can safely remove it. If it is indeed a valid version, then why is it so old??? It seems to be conflicting with a build of WinPE 2.0 from Windows Automated Installation Kit... -- jclarkw