Results 1 to 2 of 2

Thread: Expert Rule Allow Port - No worky

  1. #1
    richzonezap Guest

    Default Expert Rule Allow Port - No worky

    I used to use Expert Rules successfully with Zone Alarm Pro to allow traffic to/from specific ports. Over the last four years i have never been able to get this to work with Zone Alarm Internet Security Suite and Zone Alarm Extreme Security. Until recently, just trying to save an expert rule that does this would cause a blue screen. Now it saves it, but it has no effect.

    I have ZAES 10.1.079, Win7 64bit Home, 8GB RAM
    Public Zone, High Security

    I am trying to allow packets with a particular destination port (25565) to reach my machine. I have the router configured to port forward to my machine. I see the Zone Alarm log entries on my machine showing that the packets were incoming on my machine, with destination port 25565 and Blocked. Here is the expert rule:
    <firewall><expert><rules>
    <rule enable="true" name="TestDestPort">
    <execute action="allow" alert="client" log="logdb"/>
    <protocols>
    <tcpudpprotocol description="TestDestPortProt" dstport="25565" protocol="IP_TCP" srcport="None"/>
    </protocols>
    </rule>
    </rules></expert></firewall>

    I know I can go to Advanced Firewall, Settings, Advanced Settings, Public Zone, High Security Settings, check Allow incoming TCP ports: 25565, and it will work. Its just maddening that the Expert rule doesn't accomplish the same thing. If the Expert Rule were functioning as expected, 1) it should work, and 2) I should see a log entry where it says "Allow" instead of Blocked, which would also allow me to see which Source IPs from the internet were connecting, something the Allow incoming TCP ports does not do.

    Any thoughts on why the Expert Rule doesn't do what I think it should do, and what it used to be able to do?

  2. #2
    Join Date
    Dec 2005
    Posts
    9,056

    Default Re: Expert Rule Allow Port - No worky

    something like this maybe of help?



    http://forums.zonealarm.com/showthre...ht=expert+rule

    or

    http://forums.zonealarm.com/showthre...ht=expert+rule

    guessing maybe the ingress port should be the destination port and maybe it is instead presently set an outgress port.

    perhaps setting the correct ip could be helpful.
    Best regards.
    oldsod

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Block Expert Rule
    By alejandra in forum ZoneAlarm Configuration
    Replies: 0
    Last Post: April 5th, 2009, 08:16 AM
  2. No Firewall expert rule Alert
    By mgrisoni in forum Windows and ZoneAlarm Messages and Alerts
    Replies: 7
    Last Post: August 9th, 2007, 12:17 PM
  3. Firewall expert "Block all" rule blocks access before reading any Program expert rules?
    By tjmachineman in forum General - Questions that don't fit any other category
    Replies: 8
    Last Post: December 9th, 2005, 04:32 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •