My Windows XP Home SP1 installation CD installs a version not compatible with current ZA. I think I need at least SP2. My PC will be without any firewall protection while windows updates to SP2, could someone give me a suggestion?