Results 1 to 8 of 8

Thread: Taskbar Clock won't run

  1. #1
    JJMartin Guest

    Default Taskbar Clock won't run

    I just upgraded to ZoneAlarm Free version 10.2.047.000.

    Now Taskbar Clock (tclockex142.exe) won't run, it says "Cannot hook the clock".
    A search of the internet found this happened to someone with ZoneAlarm version 8, he reverted to the previous version and it worked.
    I never had this problem before in the many years I've been using ZoneAlarm Free.
    Hope they fix it soon, I don't like running old versions if I can help it.

  2. #2
    Join Date
    Jun 2006
    Location
    The 3rd Coast - South Central Texas
    Posts
    10,466

    Default Re: Taskbar Clock won't run

    Hi;

    Sorry, this sounds like you have not configured ZA correctly and not a problem with Zone Alarm..

    are you still engaging the "STOP" feature?

    "I often set Stop All Internet Activity when doing video recording."
    Internet lock (STOP) is not advised at all. It will cause your PC to loose internet connection and can cash other components of the Windows OS.

    Last edited by GeorgeV; May 11th, 2012 at 08:51 AM.

  3. #3
    davidrbc Guest

    Default Re: Taskbar Clock won't run

    I too recently updated to

    ZoneAlarm Free Firewall version: 10.2.064.000
    Vsmon version: 10.2.064.000
    Driver version: 10.2.064.000
    Web Identity Protections version: 1.5.388.0

    and found that Tclockex was unable to start with the message "Cannot hook the clock". The utility was working correctly before the Zonealarm upgrade which leads me to believe that Zonealarm is the cause.

    Is it possible to find a previous version of and replace the above version to allow Tclockex to run?

  4. #4
    Join Date
    Dec 2002
    Location
    San Carlos, California
    Posts
    1,636

    Default Re: Taskbar Clock won't run

    Hello,

    Just did a quick test and tclockex works just fine with the latest version 10.2.072.000

    BUT, this software is 12 to 6 years old and has not been updated in that amount of time. The software does not officially support Win 7

    The creators of the software are no longer online and there website is gone.

    So with that if there is an issue with your particular installation and tclockex, ZA will not be fixing it due to the very old age and lack of any support or updates from the authors. We suggest you find another clock application.

    How we tested was on a Windows XP SP3 system that already has ZA version 10.2.072 installed and running. We downloaded tclockex from cnet and installed. The application installed and showed up as the enhanced clock in the task bar and there were no errors.

    Our ZA was a default install and none of the setting where change in any way.

    So you may have changed the default setting in ZA and that may be causing you the error or when you upgraded ZA tclockex didn't like that.

    So try uninstalling tclockex and also uninstalling your older version of ZA and download the latest version of ZA 10.2.072 and install it making sure its working.

    Then go to cnet and download the last known update of this very very old software tclockex and install it.

    If it still does not work remove tclockex and search for a new clock program because there are probably dozens of them out there that are free and are actually still supported by there authors unlike tclockex.

    Forum Moderator
    Click here for ZA Support
    Monday-Saturday__ 6am to 10pm Central time
    Closed Sundays and Holidays

  5. #5
    fishwacker Guest

    Default TClockEx "Cannot hook" error on WinXP

    TClockEx will not load when the current version of ZA is running on WinXP. The "SetWindowsHookEx " function will not execute, preventing the loader from running. I believe the "hook" links a procedure into the system clock to get the time, but that's beyond my grade level. This is a problem with ZA. The work around is either (1) to load ZA manually after TClock starts or (2) close ZA, load TClock, then restart ZA. The fix is to change the load order of the programs as shown in "start" then "run" then "msconfig". This requires messing with the registry and directions can be found on the web, and it assumes ZA does not start any "services" but only runs as a program. I have not tested this approach.

  6. #6
    Join Date
    Nov 2004
    Location
    localhost
    Posts
    17,291

    Default Re: TClockEx "Cannot hook" error on WinXP

    A search before posting could have helped:http://www.zonealarm.com/forums/show...485#post294485. Thanks,Fax
    Last edited by fax; December 14th, 2012 at 05:16 AM.

    Click here for ZA Support
    Monday-Saturday 6am to 10pm Central time
    Closed Sundays and Holidays

  7. #7
    Join Date
    Dec 2008
    Posts
    2

    Default Tray Clock

    Been using ZA and TClockEx for years. Just switched to ZA+antivirus and ditched AVG and Lavasoft. Now TClockEx no longer works. I tried two other clocks and they do not work. I have read the other forum posts on TClockEx and yes it is an old program but so are a lot of other apps that still work just fine. How do I get ZA+antivirus to let a tray clock program hook the clock? I am running XP SP3 with all updates.

  8. #8
    Join Date
    Nov 2004
    Location
    localhost
    Posts
    17,291

    Default Re: Taskbar Clock won't run

    Sorry, the steps to resolved the issue are already been explained we cannot really address more than what already said above.

    Make sure that you are running the latest ZA version and that you have NOT changed any default settings. As licensed user you can also contact ZA support. But I afraid they will not be able to resolved it as already explained above.

    I have merged the different created thread on the subject in one as the core issue discussed seems exactly the same.

    Thanks,
    Fax

    Click here for ZA Support
    Monday-Saturday 6am to 10pm Central time
    Closed Sundays and Holidays

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Anti-virus scanning is de-Activated.This can occur if the system clock has been set f
    By olivermyers in forum ZoneAlarm Anti-virus & Anti-spyware
    Replies: 12
    Last Post: January 1st, 2010, 06:54 PM
  2. Replies: 10
    Last Post: March 11th, 2008, 06:14 PM
  3. First installation starts clock on all??
    By repairmanjack in forum ZoneAlarm Installation
    Replies: 2
    Last Post: January 28th, 2008, 02:49 AM
  4. Synchronizing the clock in my System Tray.
    By kentbloke in forum Access Issues
    Replies: 0
    Last Post: March 18th, 2006, 04:41 AM
  5. ZA Reset my CLOCK !
    By breaker in forum General - Questions that don't fit any other category
    Replies: 1
    Last Post: March 5th, 2006, 06:05 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •