Results 1 to 10 of 10

Thread: Zone Alarm stops an Excel macro

  1. #1
    dsscottage Guest

    Default Zone Alarm stops an Excel macro

    You will roll your eyes at this question - Sorry.

    I'm using:
    Windows XP Home SP3 (with all updates)
    Zone Alarm 10.2.064.000
    Excel 97 (OK - roll your eyes now)

    My problem:
    I'm using an Excel 97 macro (written in the old Lotus 123 language format) so that the macro can be used for data entry. (You can roll your eyes again but newer Excel versions and the VBasic macros won't allow me to pause the macro for user input.) Part of the macro does a copy and paste.

    After updating to ZoneAlarm 10.2, the macro will fail at the "paste" command. I get the error message "Cannot empty the clipboard".

    When I unload ZoneAlarm, the macro works fine.

    In ZA, Excel is assigned to "Super" trust level.

    I can manually copy and paste even if ZoneAlarm is loaded. The copy/paste function only fails in a macro.

    Any ideas?

  2. #2
    Join Date
    Nov 2004
    Location
    localhost
    Posts
    17,288

    Default Re: Zone Alarm stops an Excel macro

    Hi!

    it would be important, before trying to troubleshoot the issue, to update to the latest version of ZAfree (we are at 10.2.073.000).

    1. Remove your current ZA from XP add/remove a program:
    2. Reboot
    3. Download to desktop and run the ZA removal tool
    4. Reboot
    5. Download the lastest version of ZAfree from here:
    Looking for the latest version?
    6. Install at default, do not alter any settings to be sure to start from a clean set-up.

    Test it now and come back with results. Also specify which kind of copy/paste you do. From a program? From CTRL-C/CTRL-V. Please also mention the other security software that you have installed on the system.

    Thanks,
    Fax
    Last edited by fax; August 3rd, 2012 at 09:28 AM.

    Click here for ZA Support
    Monday-Saturday 6am to 10pm Central time
    Closed Sundays and Holidays

  3. #3
    dsscottage Guest

    Default Re: Zone Alarm stops an Excel macro

    fax - Thank-you for your speedy reply.

    I did exactly as you recommended. I'm now on ZA ver 10.2.073.000.

    I didn't use the default installation. However, the only changes that I made were to disable the installation of the ZA search homepage, toolbar and default search engine.

    My problem remains the same.

    You asked which kind of copy/paste I did:
    The command is in an Excel 97 macro using the old Lotus 123 macro language. Part of the macro is "/c{Up}~~". This means:
    /c - enter the copy mode
    {Up} - move one cell up
    ~ - copy the contents of the current cell and return to the previous cell
    ~ - paste the contents of the clipboard into the current cell
    This is where the macro fails. (Cannot empty the clipboard)

    What other security software do I have:
    Avast version 7.0.1456 (I believe that this is the latest)

    In my problem solving, I had previously disabled Avast but this didn't help.

    Any other suggestions?

  4. #4
    Join Date
    Nov 2004
    Location
    localhost
    Posts
    17,288

    Default Re: Zone Alarm stops an Excel macro

    Just to be sure it is a ZA issue try to shutdown ZA and test again
    (right click the ZA icon near the clock --> Exit --> wait a couple of minutes to be sure all processes are shutdown).

    BTW, check the ZA logs (tools --> Logs), all subsections for anything you think it is unusual.

    Click here for ZA Support
    Monday-Saturday 6am to 10pm Central time
    Closed Sundays and Holidays

  5. #5
    dsscottage Guest

    Default Re: Zone Alarm stops an Excel macro

    Thank-you again fax.

    I shut down ZA again and the macro works as expected. When I restart ZA, the macro fails again.

    I also looked at the logs and I only see one thing odd:
    The OS Firewall blocked "system32\svchost.exe" twice.
    There are usually multiple appearances of this program in Task Manager and even after these 2 blocked programs, there are still 9 appearances of svchost.exe in Task Manager.

  6. #6
    Join Date
    Nov 2004
    Location
    localhost
    Posts
    17,288

    Default Re: Zone Alarm stops an Excel macro

    The time when svchost.exe was blocked correspond to when you did your copy/paste? I think this is completely unrelated. Probably is due to the way you set up your network in the firewall zones (e.g. Internet instead of TRUSTED). Check anyway the timing to cross-check.

    Next thing to try is to go to ZA web protection and turn it OFF. Wait a minute before testing again to allow the processes to fully turn OFF (forcefield). You may need to reboot the PC. Test again and see if it works now.

    Click here for ZA Support
    Monday-Saturday 6am to 10pm Central time
    Closed Sundays and Holidays

  7. #7
    dsscottage Guest

    Default Re: Zone Alarm stops an Excel macro

    Sorry fax,

    I hate to sound like a dummy but I can't see how to turn off web protection. Do you mean Web Identity Protections? If so, it's already off. However, ForceField is loaded in Task Manager. Just in case, I terminated the process ForceField and ran the macro again. It still failed.

    The block of svchost.exe did not correspond to the copy/paste timing. It happened on boot up. My network is in the Trusted zone.

  8. #8
    Join Date
    Nov 2004
    Location
    localhost
    Posts
    17,288

    Default Re: Zone Alarm stops an Excel macro

    Uuuhm, yes Web Identity Protection. After this I am out of suggestions. You could try to turn OFF ZA application control and the rest of modules to try to identify the module conflicting.

    Well, even after having detected the module its unlikely this will be solved any time soon as lotus/excel are outdated versions and development is not likely to work on this. On top ZAfree offers no support.

    So, solution? You could keep running an old ZA version (that personally I would not recommend) or give up on ZA and find some other firewall solutions. May be other users here can suggest more actions to perform in ZA to try to workaround the problem? Who knows...

    Sorry,
    Fax

    Click here for ZA Support
    Monday-Saturday 6am to 10pm Central time
    Closed Sundays and Holidays

  9. #9
    dsscottage Guest

    Default Re: Zone Alarm stops an Excel macro

    OK. I've uninstalled ZA and installed a different firewall. (Not sure if I'm allowed to mention the name of the other firewall on the ZA forum.)

    Now my macro is working perfectly.

    This seems a shame since ZA has been my one and only firewall for a very long time. I've never had any trouble with it until now.

    Oh well, all is working now.

    Thanks again fax for all of you help. You are a star!

  10. #10
    Join Date
    Nov 2004
    Location
    localhost
    Posts
    17,288

    Default Re: Zone Alarm stops an Excel macro

    You're welcome! And good luck with your new setup

    Click here for ZA Support
    Monday-Saturday 6am to 10pm Central time
    Closed Sundays and Holidays

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Zone Alarm alert stops responding
    By z12 in forum General - Questions that don't fit any other category
    Replies: 2
    Last Post: October 13th, 2010, 09:40 AM
  2. Zone alarm stops some network access
    By nigelpr in forum ZoneAlarm Installation
    Replies: 1
    Last Post: November 11th, 2008, 07:02 AM
  3. Zone Alarm stops my printer from working
    By dflanagan in forum Malware Discussion
    Replies: 2
    Last Post: September 10th, 2008, 02:58 AM
  4. Zone alarm stops me going to hyperlinks
    By wildlife in forum Windows and ZoneAlarm Messages and Alerts
    Replies: 1
    Last Post: October 22nd, 2007, 05:25 AM
  5. Zone Alarm Stops Responding
    By taerepted in forum General - Questions that don't fit any other category
    Replies: 3
    Last Post: November 9th, 2006, 10:02 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •