Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Zone Alarm Security Engine 1.5.395.0

  1. #1
    John Butcher Guest

    Exclamation Zone Alarm Security Engine 1.5.395.0

    Hello,

    I am using Zone Alarm free firewall (without antivirus) 10.2.073.000
    Firefox 14.0.1
    Zone Alarm Security Engine 1.5.395.0

    When I launch Firefox I get this error message:

    unload: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIObserverService.removeObserver]" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: chrome://trustchecker/content/trustchecker.js :: <TOP_LEVEL> :: line 991" data: no]

    If I disable the security engine add-on, it does not appear. Hence I deduce that it is a problem with this, or maybe it has an incompatibility with another plug-in.

    Has anyone any comments please?

    Thank you,

    John Butcher.

  2. #2
    Join Date
    Dec 2002
    Location
    San Carlos, California
    Posts
    1,636

    Default Re: Zone Alarm Security Engine 1.5.395.0

    We haven not experienced that error during QA or in house systems.

    Very well could be a conflict with another plug-in.

    What other plug-ins do you have?


    Forum Moderator
    Click here for ZA Support
    Monday-Saturday__ 6am to 10pm Central time
    Closed Sundays and Holidays

  3. #3
    Join Date
    Aug 2009
    Location
    Texas Gulf Coast
    Posts
    1,643

    Default Re: Zone Alarm Security Engine 1.5.395.0

    Just suggestion to try resolve error message issue.

    TrustChecker: TrustChecker.dll is part of ZoneAlarm ForceField.

    Path: C:\Program Files\CheckPoint\ZAForceField\ForceField.exe

    Check with Task Manager / Process Explorer.Do you see ForceField.exe in the Processes tab." If not." I would then suggest to re-download installer and clean uninstall & install.

    Also when you install with option to install Zonealarm Security Toolbar for Anti- phishing / Web Protection function offered in the ZoneAlarm Free Firewall.First time you open Firefox 14.0.1.Do this when first open Firefox after Zonealarm install..

    When requested add-on ( ForceField Toolbar x.x.xxx.x ) will ask you to confirm that you want to install it.

    Tick to enable and Click " Allow this installation " Click Continue and then Click Restart Firefox.

    I have no other suggestions to offer.Maybe other users might offer input.

    Have a nice Day
    Last edited by Sky Soldiers; August 7th, 2012 at 08:18 AM. Reason: Typo, & rephrase

  4. #4
    John Butcher Guest

    Default Re: Zone Alarm Security Engine 1.5.395.0

    Hello,

    Thank you both very much for your replies. I have found the problem - I have two Zone Alarm plug-ins in Firefox:

    Zone Alarm Security Engine 1.5.395.0 'Safe browsing toolbar' and
    zonealarm.com 1.6.0 'ZoneAlarm toolbar for Firefox'.

    It would seem that I cannot run them both, but when I disable either one the error message does not appear.

    Is it better to keep the security engine and remove the other, or the other way around please?

    Thank you.

  5. #5
    Join Date
    Aug 2009
    Location
    Texas Gulf Coast
    Posts
    1,643

    Default Re: Zone Alarm Security Engine 1.5.395.0

    Quote Originally Posted by John Butcher View Post

    Is it better to keep the security engine and remove the other, or the other way around please?
    Using ZoneAlarm Extreme Security version: 10.2.073.000.I have the following.Not sure about ZoneAlarm Free Firewall.

    Under Extensions there is ForceField Toolbar 1.5.395.0 & zonealarm.com 1.6.0

    Under Plugins there is npFFApi 1.0.0.1

    I think you just have bad install.Try what suggested to re-download installer and clean uninstall & re-install.

    Out of suggestions here since I've never use ZoneAlarm Free Firewall.Sorry

    Have a nice Day
    Last edited by Sky Soldiers; August 7th, 2012 at 11:04 AM. Reason: Out of suggestions

  6. #6
    AndreH Guest

    Default Re: Zone Alarm Security Engine 1.5.395.0

    John

    I have had the exact same error as you when attempting to run Firefox 14. I have installed ZA Extreme versions 10.2.072 then 10.2.073 with the

    same problem.

    Things I have tried.
    + Disable all the add-ons in Firefox before install
    + clear virtual data
    + The standard uninstall, clean.exe, ff_cleanup.cmd, ccleaner and then reinstall
    + Help from Online Support Chat

    (Sky Soldiers) Forcefield is running in the process list.

    What is working:
    + Download protection
    + Browser virtualization. > Firefox has a halo, but ISWMGR.exe not started ??
    > Internet Explorer has halo and ISWMGR.exe started and functions correctly

    What does not work:
    + Firefox -> Zonealarm Security Engine not started
    + Zonealarm toolbar - no site checking
    -If you press [Youtube] on you get the same error as below

    Andre


    Error on starting Firefox:

    unload: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIObserverService.removeObserver]" nsresult:
    "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: chrome://trustchecker/content/trustchecker.js :: <TOP_LEVEL> :: line 991" data: no]


    Current Install
    ===============

    Win XP sp3, Java 1.6.0_33

    Firefox 14.0.1 with
    * Extensions: ForceField Toolbar 1.5.395.0 & zonealarm.com 1.6.0
    * Plugins: npFFApi 1.0.0.1

    ZoneAlarm Extreme Security version: 10.2.073.000
    ZoneAlarm license key:
    Vsmon version: 10.2.073.000
    Driver version: 10.2.073.000
    Antivirus engine version: 8.2.11.97
    Antivirus signature DAT file version: 1091054144
    AntiSpam version: 6.3.1.4971
    ZoneAlarm Browser Security: 1.5.395.0
    ZoneAlarm ForceField Spyware Scanner: 1.2.104.0

  7. #7
    Join Date
    Nov 2004
    Location
    localhost
    Posts
    17,284

    Default Re: Zone Alarm Security Engine 1.5.395.0

    I have seen this before and the only way to rectify it was to clean install fully Firefox including manually removing 'mozilla' folders in user profile, roaming, local, hidden application data folder, etc as the current Firefox does not always remove old files/folders from previous versions. If you still get errors then you have not found all files and folders to remove.

    So, the steps to follow (same order) would be:

    1. Fully remove ZA, run clean.exe, hunt for checkpoint folders still in HD. Reboot the PC.
    2. Fully remove Firefox, hunt for left overs above mentioned
    3. Reinstall FF at default, open it, browse to somewhere to let it create the profile. Close it.
    4. Install ZA, wait that everything is loaded.
    5. Reboot the PC, even if ZA does not ask you

    ** Note: ZoneAlarm and Java7 --> You need latest JAVA 6**

    Thanks,
    Fax
    Last edited by fax; August 7th, 2012 at 11:21 PM.

    Click here for ZA Support
    Monday-Saturday 6am to 10pm Central time
    Closed Sundays and Holidays

  8. #8
    Join Date
    Aug 2009
    Location
    Texas Gulf Coast
    Posts
    1,643

    Default Re: Zone Alarm Security Engine 1.5.395.0

    AndreH : Yes, Guru fax is correct you have a corrupt profile.That's why I never install over the top.I always clean install Firefox for this very reason.Especially when installing Zonealarm Security Toolbar.

    A corrupt profile can cause various problems with Firefox.You could create a new profile using Profile Manager.I prefer to reinstall Firefox.

    Backup your Bookmarks(.json) to a folder of your choice.You will need it to restore it later.Uninstall Firefox and do not save your settings when asked.After uninstalling Firefox run CCleaner.

    Install Firefox.When installing Firefox select do nothing when ask to import from IE.Restore .json backup file you saved to restore your Bookmarks.Configure all your Firefox settings.Install Add-ons and Plugins.

    Install ZoneAlarm Extreme Security version: 10.2.073.000 using defaults.

    When first installing ZoneAlarm Extreme Security in Firefox 10 and above .The requested add-on ( ForceField Toolbar x.x.xxx.x ) will ask you to confirm that you want to install it.

    Tick to enable and Click " Allow this installation "Click Continue and then Click Restart Firefox.After Restart of Firefox make sure Site Check is Enable ( Green ).

    Close Firefox and then Turn ON Browser Virtualization.It's Off by default at install.

    Footnote: Always turn Browser Virtualization OFF when configuring Firefox.This is also valid for installing Add-ons and Plugins.

    Version 6 Update 33 :

    http://www.java.com/en/download/manual_v6.jsp

    Have a nice Day

  9. #9
    John Butcher Guest

    Default Re: Zone Alarm Security Engine 1.5.395.0

    Thank you very much to everyone for all the advice. I'll try the uninstalling, clearing out and re-installing at the weekend!

    John.

  10. #10
    John Butcher Guest

    Default Re: Zone Alarm Security Engine 1.5.395.0

    Hello again,

    I tried this twice but I still can't get the security engine to run, though at least I no longer get the wrror message on start up. Perhaps I'll try again later. Thank you for your help even so.

    John.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Zone Alarm Security Engine AddOn for Firefox 8.01
    By galton in forum ZoneAlarm Free Firewall
    Replies: 1
    Last Post: October 16th, 2012, 10:55 PM
  2. Run ZASS without the browser security engine?
    By rickola in forum ZoneAlarm Installation
    Replies: 7
    Last Post: January 25th, 2012, 01:41 PM
  3. ZoneAlarm Security Engine Toolbar
    By joeii in forum ZoneAlarm Free Firewall
    Replies: 5
    Last Post: December 9th, 2010, 03:59 PM
  4. Q about FireFox and ZoneAlarm Security Engine
    By Huskyhund in forum ZoneAlarm Free Firewall
    Replies: 1
    Last Post: August 25th, 2010, 06:02 AM
  5. Search engine and Zone Alarm
    By servates in forum General - Questions that don't fit any other category
    Replies: 1
    Last Post: April 23rd, 2006, 03:29 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •