OK, I waited ages for a supposed fix to the previously known "update failure" issue, but once I updated to 0.74 I thought the issues had been fixed since the "at risk" message disappeared, but after a week it has appeared again.

Version 10.2.074 STILL won't update for me, giving a "zone alarm update overdue" message.

Thoughts?