The past several times I have upgraded Firefox browser, there is a Box from Zone Alarm reflecting "This is unstable"..... Then there is another box shortly after that which states "ZA must close now".

I finally managed to DL and install the current version which is 16.0.2 and thus far, no problems, however had to close the ZAES program prior to accomplishing this.

I have found that the only way I can upgrade Firefox to the latest version is to turn the ZAES off (paid Version 10.2.078.000). OS is XP. I have had a difficult time with the two versions which I finally downloaded and installed, and they caused problems.

Is there any reason for these boxes popping up and preventing a clean download? Anyone else having this problem? Thanks for any advice you may have to offer.
Hanging