Have been advised by Firefox to update to Version 18
When I try to do so it says that ZA is not compatible.
I contacted ZA Live Chat and really got what I consider to be a less than satisfactory answer "We are aware of this but I have no idea when it will be made compatible -we have to wait for the developers to advise us" to the question "when will it be compatible" to enable me to update FF
I have only recently started to try out ZoneAlarm PRO Antivirus + Firewall and found it a little frustrating and disturbing that this was the best answer I was able to get.

Norman Holden