To whom it may concern,

Up until about 3 days ago I was using an older version of ZA-ES and was happy with it - but three days ago the application forced me to upgrade to the latest version.


The issue I am having is when the update was completed to the new version, connections to postgresql became extremely slow - and difficult to work with for pgadmin 3.

So with that, I thought what the heck - its been 3 years since my last clean format of my OS and brought everything up to the latest versions.

So I have just performed a clean installation of Windows 7 Ultimate - with SP1 and all microsoft updates, and re-installed everything - everything was working correctly, including the pgadmin3 and postgresql.

the final software I have installed - is ZA-ES - via the web downloader and now the connection via pgAdmin is not working/or extremely slow.

My ZA about is below
===============

ZoneAlarm Extreme Security version: 13.1.211.000
ZoneAlarm license key: <removed>
Vsmon version: 13.1.211.0
Driver version: 13.1.123.0
Antivirus engine version: 8.3.4.4
Antivirus signature DAT file version: 1154841152
AntiSpam version: 6.3.1.4973


===============

The details - there is little to be found on Google about ZA and Postgre except that they seem to not like each other at all....



What I have tried to do:

===============
http://www.clarion-software.com/inde...597239&group=1

SOLUTION:

The solution was to go into the "Firewall | Zones" tab of Zone Alarm and add a Local Host entry with an IP of 127.0.0.1"

but this did not work

===============

I also tried going to the application control and selecting "PostgreSQL Server"->options

- enabled this program may use other programs to access the internet
- allow application interaction

i also added an expert rule adding any protocol, port etc

===============

I did the above for pgAdmin3 as well....


would someone please be able to make some suggestions that might help me resolve this extremely slow connection to the database?


Thanks heaps in advance.